summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2016-11-28 21:52:22 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-03 07:21:54 +0700
commitb53788225783a4154bc1c7f58556cbe2fcab2110 (patch)
treeb90f8c475a49e38c4df9cfa96fde8de450df74e3 /python
parent350c6df1da3868fed6fdf6fbca74adc97d0ebc28 (diff)
downloadslackbuilds-b53788225783a4154bc1c7f58556cbe2fcab2110.tar.gz
slackbuilds-b53788225783a4154bc1c7f58556cbe2fcab2110.tar.xz
python/python-sh: Updated for version 1.12.2
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-sh/README4
-rw-r--r--python/python-sh/python-sh.SlackBuild10
-rw-r--r--python/python-sh/python-sh.info6
3 files changed, 12 insertions, 8 deletions
diff --git a/python/python-sh/README b/python/python-sh/README
index c1002feea6..e1c4d96069 100644
--- a/python/python-sh/README
+++ b/python/python-sh/README
@@ -6,3 +6,7 @@ from sh import ifconfig
print(ifconfig("wlan0"))
Optional dependency: python3
+
+Note: Pass PYTHON3=yes to the slackbuild for pyhton 3 support.
+
+ # PYTHON3="yes" ./python-sh.SlackBuild
diff --git a/python/python-sh/python-sh.SlackBuild b/python/python-sh/python-sh.SlackBuild
index 61c0b9ff78..bc53982e33 100644
--- a/python/python-sh/python-sh.SlackBuild
+++ b/python/python-sh/python-sh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-sh
-# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-sh
-VERSION=${VERSION:-1.11}
+VERSION=${VERSION:-1.12.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -57,7 +57,7 @@ find -L . \
python setup.py install --root=$PKG
-if $(python3 -c 'import os' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py install --root=$PKG
fi
@@ -65,7 +65,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS.md LICENSE.txt PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt *.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python-sh/python-sh.info b/python/python-sh/python-sh.info
index bfe76e9c23..3da697cb2a 100644
--- a/python/python-sh/python-sh.info
+++ b/python/python-sh/python-sh.info
@@ -1,8 +1,8 @@
PRGNAM="python-sh"
-VERSION="1.11"
+VERSION="1.12.2"
HOMEPAGE="http://amoffat.github.com/sh/index.html"
-DOWNLOAD="http://pypi.python.org/packages/source/s/sh/sh-1.11.tar.gz"
-MD5SUM="7af8df6c92d29ff927b6db0146bddec3"
+DOWNLOAD="https://pypi.python.org/packages/dd/28/b09cbf6941dcec3b3138e7bfba08e2fc4aca041912be5189e50f706848a0/sh-1.12.2.tar.gz"
+MD5SUM="62f322f720f32f8af896f1572b1c1053"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""