summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Hunter Sezen <ovariegata@yahoo.com>2017-01-15 23:38:06 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-21 07:04:21 +0700
commitc4d9cb0a33e1c7b40b92aee9e88e17f8d665d29a (patch)
treecce786c69379d27ecc0e05e687a8cada4c9cc559 /python
parent5278f8bd1f3335c46dc13e38d2ffa02884d5f29b (diff)
downloadslackbuilds-c4d9cb0a33e1c7b40b92aee9e88e17f8d665d29a.tar.gz
slackbuilds-c4d9cb0a33e1c7b40b92aee9e88e17f8d665d29a.tar.xz
python/pyewmh: Added (Extended Window Manager Hints for python).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyewmh/README5
-rw-r--r--python/pyewmh/pyewmh.SlackBuild73
-rw-r--r--python/pyewmh/pyewmh.info10
-rw-r--r--python/pyewmh/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/python/pyewmh/README b/python/pyewmh/README
new file mode 100644
index 0000000000..8259e9af80
--- /dev/null
+++ b/python/pyewmh/README
@@ -0,0 +1,5 @@
+An implementation of EWMH (Extended Window Manager Hints) for python,
+based on Xlib. It allows EWMH-compliant window managers (most modern
+WMs) to be queried and controlled.
+
+Python3 is an optional dependency.
diff --git a/python/pyewmh/pyewmh.SlackBuild b/python/pyewmh/pyewmh.SlackBuild
new file mode 100644
index 0000000000..99931c5cc6
--- /dev/null
+++ b/python/pyewmh/pyewmh.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for pyewmh
+
+# Copyright 2016-2017 Hunter Sezen California, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyewmh
+VERSION=${VERSION:-0.1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if python3 -c 'import sys' 2>/dev/null; then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyewmh/pyewmh.info b/python/pyewmh/pyewmh.info
new file mode 100644
index 0000000000..aa581d7bec
--- /dev/null
+++ b/python/pyewmh/pyewmh.info
@@ -0,0 +1,10 @@
+PRGNAM="pyewmh"
+VERSION="0.1.4"
+HOMEPAGE="https://github.com/parkouss/pyewmh"
+DOWNLOAD="https://github.com/parkouss/pyewmh/archive/v0.1.4/pyewmh-0.1.4.tar.gz"
+MD5SUM="a839d66b8b71518d920524fc99f61eba"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Hunter Sezen"
+EMAIL="ovariegata@yahoo.com"
diff --git a/python/pyewmh/slack-desc b/python/pyewmh/slack-desc
new file mode 100644
index 0000000000..7b99c868cb
--- /dev/null
+++ b/python/pyewmh/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyewmh: pyewmh (Extended Window Manager Hints for python)
+pyewmh:
+pyewmh: An implementation of EWMH (Extended Window Manager Hints) for python,
+pyewmh: based on Xlib. It allows EWMH-compliant window managers (most modern
+pyewmh: WMs) to be queried and controlled.
+pyewmh:
+pyewmh: Homepage: https://github.com/parkouss/pyewmh
+pyewmh:
+pyewmh:
+pyewmh:
+pyewmh: