summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2017-01-28 23:19:45 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-04 06:59:27 +0700
commitda1f20a28a1070143f81bd8aa25bb1b85c0fa092 (patch)
tree617d1142b48047d92856bc392d83a65198475e02 /python
parentc2b699753b0b54302791a822751d6c62cf0febed (diff)
downloadslackbuilds-da1f20a28a1070143f81bd8aa25bb1b85c0fa092.tar.gz
slackbuilds-da1f20a28a1070143f81bd8aa25bb1b85c0fa092.tar.xz
python/zxcvbn-python: Added (password strength estimator).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/zxcvbn-python/README1
-rw-r--r--python/zxcvbn-python/slack-desc19
-rw-r--r--python/zxcvbn-python/zxcvbn-python.SlackBuild85
-rw-r--r--python/zxcvbn-python/zxcvbn-python.info10
4 files changed, 115 insertions, 0 deletions
diff --git a/python/zxcvbn-python/README b/python/zxcvbn-python/README
new file mode 100644
index 0000000000..d9e6f4fc81
--- /dev/null
+++ b/python/zxcvbn-python/README
@@ -0,0 +1 @@
+Python implementation of Dropbox’s realistic password strength estimator.
diff --git a/python/zxcvbn-python/slack-desc b/python/zxcvbn-python/slack-desc
new file mode 100644
index 0000000000..6e3fc330f9
--- /dev/null
+++ b/python/zxcvbn-python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+zxcvbn-python: zxcvbn-python (Dropbox's Python password strength estimator)
+zxcvbn-python:
+zxcvbn-python: Python implementation of Dropbox's realistic password strength
+zxcvbn-python: estimator.
+zxcvbn-python:
+zxcvbn-python: Homepage: https://github.com/dwolfhub/zxcvbn-python
+zxcvbn-python:
+zxcvbn-python:
+zxcvbn-python:
+zxcvbn-python:
+zxcvbn-python:
diff --git a/python/zxcvbn-python/zxcvbn-python.SlackBuild b/python/zxcvbn-python/zxcvbn-python.SlackBuild
new file mode 100644
index 0000000000..f50781bad1
--- /dev/null
+++ b/python/zxcvbn-python/zxcvbn-python.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for zxcvbn-python
+
+# Copyright 2017 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=zxcvbn-python
+VERSION=${VERSION:-4.4.13}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/zxcvbn-python/zxcvbn-python.info b/python/zxcvbn-python/zxcvbn-python.info
new file mode 100644
index 0000000000..a9da79d487
--- /dev/null
+++ b/python/zxcvbn-python/zxcvbn-python.info
@@ -0,0 +1,10 @@
+PRGNAM="zxcvbn-python"
+VERSION="4.4.13"
+HOMEPAGE="https://github.com/dwolfhub/zxcvbn-python"
+DOWNLOAD="https://pypi.python.org/packages/b3/bc/3f00dbcfe43e592c5e694e0e98c524dbd41ccd63b4ea3e56385cdb3a7f33/zxcvbn-python-4.4.13.tar.gz"
+MD5SUM="6d5d2c9704477f02f63f85fc9ea5364d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"