summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2016-07-09 07:47:03 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-07-09 07:47:03 +0700
commitdde8c063c5cc4e9b8820e7457ae8ae1b4c803004 (patch)
tree1fe2b6615b00da18b93476444b8fe03539271b84 /python
parent016fb691edd320b5193e1640ca1f3384595f2150 (diff)
downloadslackbuilds-dde8c063c5cc4e9b8820e7457ae8ae1b4c803004.tar.gz
slackbuilds-dde8c063c5cc4e9b8820e7457ae8ae1b4c803004.tar.xz
python/pyperclip: Updated for version 1.5.27.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyperclip/pyperclip.SlackBuild9
-rw-r--r--python/pyperclip/pyperclip.info6
2 files changed, 10 insertions, 5 deletions
diff --git a/python/pyperclip/pyperclip.SlackBuild b/python/pyperclip/pyperclip.SlackBuild
index 2b7cac0b17..be7fd3b001 100644
--- a/python/pyperclip/pyperclip.SlackBuild
+++ b/python/pyperclip/pyperclip.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyperclip
-# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2016 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
# PDF Documentation downloaded from pyperclip.readthedocs.org 12/1/2015
PRGNAM=pyperclip
-VERSION=${VERSION:-1.5.25}
+VERSION=${VERSION:-1.5.27}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,6 +74,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/pyperclip/pyperclip.info b/python/pyperclip/pyperclip.info
index 0fe0233d72..8ca1f99453 100644
--- a/python/pyperclip/pyperclip.info
+++ b/python/pyperclip/pyperclip.info
@@ -1,8 +1,8 @@
PRGNAM="pyperclip"
-VERSION="1.5.25"
+VERSION="1.5.27"
HOMEPAGE="https://github.com/asweigart/pyperclip"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pyperclip/pyperclip-1.5.25.zip"
-MD5SUM="344e45b6eae6df72fe768b0baae03fc8"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyperclip/pyperclip-1.5.27.zip"
+MD5SUM="18b86c2e6d10ed827cdd42aed80b4cbe"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""