summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libraries/stfl/fix-python-install-in-Makefile.patch13
-rw-r--r--libraries/stfl/stfl.SlackBuild4
2 files changed, 16 insertions, 1 deletions
diff --git a/libraries/stfl/fix-python-install-in-Makefile.patch b/libraries/stfl/fix-python-install-in-Makefile.patch
new file mode 100644
index 0000000000..689c88330e
--- /dev/null
+++ b/libraries/stfl/fix-python-install-in-Makefile.patch
@@ -0,0 +1,13 @@
+diff -Nur stfl-0.22.a/python/Makefile.snippet stfl-0.22.b/python/Makefile.snippet
+--- stfl-0.22.a/python/Makefile.snippet 2009-06-18 01:27:16.000000000 -0700
++++ stfl-0.22.b/python/Makefile.snippet 2012-10-05 18:24:00.912721777 -0700
+@@ -33,8 +33,7 @@
+
+ install_python: python/_stfl.so python/stfl.py python/stfl.pyc
+ mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/
+- mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
+- cp python/_stfl.so $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
++ cp python/_stfl.so $(DESTDIR)$(PYTHON_SITEARCH)/
+ cp python/stfl.pyc $(DESTDIR)$(PYTHON_SITEARCH)/
+ cp python/stfl.py $(DESTDIR)$(PYTHON_SITEARCH)/
+
diff --git a/libraries/stfl/stfl.SlackBuild b/libraries/stfl/stfl.SlackBuild
index 0cda67b558..5a10f40af8 100644
--- a/libraries/stfl/stfl.SlackBuild
+++ b/libraries/stfl/stfl.SlackBuild
@@ -7,7 +7,7 @@
PRGNAM=stfl
VERSION=${VERSION:-0.22}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -54,6 +54,8 @@ find . \
# Allow custom options in Makefile
patch -p1 < $CWD/allow-custom-opts-in-Makefile.patch
+# Fix the install directory for Python
+patch -p1 < $CWD/fix-python-install-in-Makefile.patch
make install \
OPTS="$SLKCFLAGS" \