summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2013-10-30 23:41:24 -0500
committer Robby Workman <rworkman@slackbuilds.org>2013-10-30 23:45:38 -0500
commit4a05a20923cbef25bc79aba6f48d0e72b456a46a (patch)
tree8d382609a42c793315421b85c614282b8d3535ca
parent6d107aed90f65a8fcd1c5fcb7a839a3a8764e183 (diff)
downloadtemplates-4a05a20923cbef25bc79aba6f48d0e72b456a46a.tar.gz
templates-4a05a20923cbef25bc79aba6f48d0e72b456a46a.tar.xz
templates: check for mode 640 in permissions
Thanks to Nick Warne <nick@linicks.net> for the suggestion.
-rw-r--r--autotools-template.SlackBuild4
-rw-r--r--cmake-template.SlackBuild4
-rw-r--r--perl-template.SlackBuild4
-rw-r--r--python-template.SlackBuild4
4 files changed, 8 insertions, 8 deletions
diff --git a/autotools-template.SlackBuild b/autotools-template.SlackBuild
index 6aa5b31..da5f61e 100644
--- a/autotools-template.SlackBuild
+++ b/autotools-template.SlackBuild
@@ -97,8 +97,8 @@ chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Your application will probably need different configure flags;
# these are provided as an example only.
diff --git a/cmake-template.SlackBuild b/cmake-template.SlackBuild
index b15bcae..6e0b866 100644
--- a/cmake-template.SlackBuild
+++ b/cmake-template.SlackBuild
@@ -94,8 +94,8 @@ chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Your application will probably need different cmake flags; these are only
# examples. You might use 'ccmake' to see the available flags...
diff --git a/perl-template.SlackBuild b/perl-template.SlackBuild
index ba9cb21..298e76e 100644
--- a/perl-template.SlackBuild
+++ b/perl-template.SlackBuild
@@ -96,8 +96,8 @@ chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Your application may need different flags; these are provided as examples
# There seem to be two different methods for building perl apps:
diff --git a/python-template.SlackBuild b/python-template.SlackBuild
index 712a7a7..fc98132 100644
--- a/python-template.SlackBuild
+++ b/python-template.SlackBuild
@@ -94,8 +94,8 @@ chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Your application may need different options; this is only an example
python setup.py install --root=$PKG