SlackBuilds Repository

15.0 > Academic > cholmod (3.0.14)

CHOLMOD is a set of ANSI C routines for sparse Cholesky factorization
and update/downdate.

This package is part of SuiteSparse.

This requires a BLAS/LAPACK implementation. Choose one of these
package sets:
* OpenBLAS (includes both a BLAS and a LAPACK implementation)
* atlas (includes both a BLAS and a LAPACK implementation)
* blas, lapack (the Netlib reference implementations)
If more than one set is installed (assuming there are no packaging
conflicts) then the auto-detection will use the first implementation
from this list that it finds. If in doubt, choose the Netlib
reference implementations; other packages that require a BLAS or
LAPACK implementation may not build if they are not configured to
detect/use alternate implementations.

metis is an optional dependency and will be used if found.

This requires: suitesparseconfig, blas, lapack, amd, camd, ccolamd, colamd

Maintained by: Kyle Guinn
Keywords:
ChangeLog: cholmod

Homepage:
http://faculty.cse.tamu.edu/davis/suitesparse.html

Source Downloads:
SuiteSparse-5.8.1.tar.gz (c414679bbc9432a3def01b31ad921140)

Download SlackBuild:
cholmod.tar.gz
cholmod.tar.gz.asc (FAQ)

(the SlackBuild does not include the source)

Individual Files:
README
cholmod.SlackBuild
cholmod.info
patches
slack-desc

Validated for Slackware 15.0

See our HOWTO for instructions on how to use the contents of this repository.

Access to the repository is available via:
ftp git cgit http rsync

© 2006-2022 SlackBuilds.org Project. All rights reserved.
Slackware® is a registered trademark of Patrick Volkerding
Linux® is a registered trademark of Linus Torvalds